<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>Come rain, sleet or snow - The Torch</title>
    <meta charset="UTF-8" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="http://www.lcctorch.com/xmlrpc.php" />
    <meta name="author" content="Marek Belka">
<link rel="icon" type="image/png" href="http://www.lcctorch.com/wp-content/uploads/2019/02/torchflag.jpg"><link rel="apple-touch-icon-precomposed" sizes="76x76" href="http://www.lcctorch.com/wp-content/uploads/2019/02/torchflag.jpg"/>
<!-- This site is optimized with the Yoast SEO plugin v9.5 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Come rain, sleet or snow - The Torch" />
<meta property="og:description" content="Even on a sunny late winter afternoon, Titan head baseball coach Josh Blunt is worried about the rain. In his office, Blunt repeatedly checks the weather forecast on his phone. The sun is shining through the windows and refracting through the crystal third-place trophies on his shelf, but Blunt isn’t convinced the weather will hold." />
<meta property="og:url" content="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/" />
<meta property="og:site_name" content="The Torch" />
<meta property="article:tag" content="artificial turf" />
<meta property="article:tag" content="big bend" />
<meta property="article:tag" content="Donovan Baldocchi" />
<meta property="article:tag" content="Head Coach Josh Blunt" />
<meta property="article:tag" content="Josh Blunt" />
<meta property="article:tag" content="junior college baseball" />
<meta property="article:tag" content="Lane Community College" />
<meta property="article:tag" content="Lane head coach Josh Blunt" />
<meta property="article:tag" content="Lane Titans" />
<meta property="article:tag" content="Matt Dallas" />
<meta property="article:tag" content="modesto california" />
<meta property="article:tag" content="mt hood saints" />
<meta property="article:tag" content="non-conference play" />
<meta property="article:tag" content="nwac" />
<meta property="article:tag" content="NWAC South" />
<meta property="article:tag" content="titan baseball" />
<meta property="article:tag" content="titan recruiting" />
<meta property="article:tag" content="Titans" />
<meta property="article:tag" content="willamette high school" />
<meta property="article:section" content="Baseball" />
<meta property="article:published_time" content="2019-02-28T00:46:21+00:00" />
<meta property="article:modified_time" content="2019-02-28T00:46:23+00:00" />
<meta property="og:updated_time" content="2019-02-28T00:46:23+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Even on a sunny late winter afternoon, Titan head baseball coach Josh Blunt is worried about the rain. In his office, Blunt repeatedly checks the weather forecast on his phone. The sun is shining through the windows and refracting through the crystal third-place trophies on his shelf, but Blunt isn’t convinced the weather will hold." />
<meta name="twitter:title" content="Come rain, sleet or snow - The Torch" />
<meta name="twitter:site" content="@lcctorch" />
<meta name="twitter:creator" content="@mgbelka" />
<script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"http://www.lcctorch.com/","sameAs":["http://@torchnewsgroup","https://www.youtube.com/channel/UCEgQMat8qjX_Lmapwy7PWug/featured?view_as=subscriber","https://twitter.com/lcctorch"],"@id":"http://www.lcctorch.com/#organization","name":"The Torch","logo":"http://www.lcctorch.com/wp-content/uploads/2019/02/torchflag.jpg"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Torch &raquo; Feed" href="http://www.lcctorch.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Torch &raquo; Comments Feed" href="http://www.lcctorch.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Torch &raquo; Come rain, sleet or snow Comments Feed" href="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.lcctorch.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=0bd67b5fa4a1428b3843394fb8943642"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css'  href='http://www.lcctorch.com/wp-includes/css/dist/block-library/style.min.css?ver=0bd67b5fa4a1428b3843394fb8943642' type='text/css' media='all' />
<link rel='stylesheet' id='media-credit-css'  href='http://www.lcctorch.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=3.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://www.lcctorch.com/wp-content/plugins/revslider/rs-plugin/css/settings.css?ver=4.6.93' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
.tp-caption a{color:#ff7302;text-shadow:none;-webkit-transition:all 0.2s ease-out;-moz-transition:all 0.2s ease-out;-o-transition:all 0.2s ease-out;-ms-transition:all 0.2s ease-out}.tp-caption a:hover{color:#ffa902}
</style>
<link rel='stylesheet' id='google_font_open_sans-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400italic%2C600italic%2C400%2C600%2C700&#038;subset=latin&#038;ver=0bd67b5fa4a1428b3843394fb8943642' type='text/css' media='all' />
<link rel='stylesheet' id='google_font_roboto-css'  href='http://fonts.googleapis.com/css?family=Roboto%3A500%2C400italic%2C700%2C500italic%2C400%2C300&#038;subset=latin&#038;ver=0bd67b5fa4a1428b3843394fb8943642' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-widget-css'  href='http://www.lcctorch.com/wp-content/plugins/author-avatars/css/widget.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='author-avatars-shortcode-css'  href='http://www.lcctorch.com/wp-content/plugins/author-avatars/css/shortcode.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='http://www.lcctorch.com/wp-content/themes/Newspaper/style.css?ver=6.1c' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-child-css'  href='http://www.lcctorch.com/wp-content/themes/Newspaper-child/style.css?ver=6.1c' type='text/css' media='all' />
<script type='text/javascript' src='http://www.lcctorch.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.lcctorch.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.lcctorch.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.tools.min.js?ver=4.6.93'></script>
<script type='text/javascript' src='http://www.lcctorch.com/wp-content/plugins/revslider/rs-plugin/js/jquery.themepunch.revolution.min.js?ver=4.6.93'></script>
<!-- OG: 2.7.0 -->
<meta property="og:image" content="http://www.lcctorch.com/wp-content/uploads/2019/02/cropped-torchflag.jpg" /><meta property="og:description" content="Even on a sunny late winter afternoon, Titan head baseball coach Josh Blunt is worried about the rain. In his office, Blunt repeatedly checks the weather forecast on his phone. The sun is shining through the windows and refracting through the crystal third-place trophies on his shelf, but Blunt isn’t convinced the weather will hold...." /><meta property="og:type" content="article" /><meta property="og:locale" content="en_us" /><meta property="og:site_name" content="The Torch" /><meta property="og:title" content="Come rain, sleet or snow" /><meta property="og:url" content="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/" /><meta property="og:updated_time" content="2019-02-27T16:46:23+00:00" /><meta property="article:tag" content="artificial turf" /><meta property="article:tag" content="big bend" /><meta property="article:tag" content="Donovan Baldocchi" /><meta property="article:tag" content="Head Coach Josh Blunt" /><meta property="article:tag" content="Josh Blunt" /><meta property="article:tag" content="junior college baseball" /><meta property="article:tag" content="Lane Community College" /><meta property="article:tag" content="Lane head coach Josh Blunt" /><meta property="article:tag" content="Lane Titans" /><meta property="article:tag" content="Matt Dallas" /><meta property="article:tag" content="modesto california" /><meta property="article:tag" content="mt hood saints" /><meta property="article:tag" content="non-conference play" /><meta property="article:tag" content="nwac" /><meta property="article:tag" content="NWAC South" /><meta property="article:tag" content="titan baseball" /><meta property="article:tag" content="titan recruiting" /><meta property="article:tag" content="Titans" /><meta property="article:tag" content="willamette high school" /><meta property="article:published_time" content="2019-02-27T16:46:21+00:00" /><meta property="article:modified_time" content="2019-02-27T16:46:23+00:00" /><meta property="article:author" content="http://www.lcctorch.com/author/marek-belka/" /><meta property="article:section" content="Baseball" /><meta property="article:section" content="Sports" /><meta property="twitter:card" content="summary" /><meta property="twitter:title" content="Come rain, sleet or snow" /><meta property="twitter:description" content="Even on a sunny late winter afternoon, Titan head baseball coach Josh Blunt is worried about the rain. In his office, Blunt repeatedly checks the weather forecast on his phone. The sun is shining through the windows and refracting through the crystal third-place trophies on his shelf, but Blunt..." /><meta property="twitter:url" content="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/" /><meta property="profile:first_name" content="Marek" /><meta property="profile:last_name" content="Belka" /><meta property="profile:username" content="Marek Belka" /><!-- /OG -->
<link rel='https://api.w.org/' href='http://www.lcctorch.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.lcctorch.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.lcctorch.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='http://www.lcctorch.com/?p=9659' />
<link rel="alternate" type="application/json+oembed" href="http://www.lcctorch.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.lcctorch.com%2F2019%2F02%2Fcome-rain-sleet-or-snow%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.lcctorch.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.lcctorch.com%2F2019%2F02%2Fcome-rain-sleet-or-snow%2F&#038;format=xml" />
		<script type="text/javascript">
			jQuery(document).ready(function() {
				// CUSTOM AJAX CONTENT LOADING FUNCTION
				var ajaxRevslider = function(obj) {
				
					// obj.type : Post Type
					// obj.id : ID of Content to Load
					// obj.aspectratio : The Aspect Ratio of the Container / Media
					// obj.selector : The Container Selector where the Content of Ajax will be injected. It is done via the Essential Grid on Return of Content
					
					var content = "";

					data = {};
					
					data.action = 'revslider_ajax_call_front';
					data.client_action = 'get_slider_html';
					data.token = 'af15931ab1';
					data.type = obj.type;
					data.id = obj.id;
					data.aspectratio = obj.aspectratio;
					
					// SYNC AJAX REQUEST
					jQuery.ajax({
						type:"post",
						url:"http://www.lcctorch.com/wp-admin/admin-ajax.php",
						dataType: 'json',
						data:data,
						async:false,
						success: function(ret, textStatus, XMLHttpRequest) {
							if(ret.success == true)
								content = ret.data;								
						},
						error: function(e) {
							console.log(e);
						}
					});
					
					 // FIRST RETURN THE CONTENT WHEN IT IS LOADED !!
					 return content;						 
				};
				
				// CUSTOM AJAX FUNCTION TO REMOVE THE SLIDER
				var ajaxRemoveRevslider = function(obj) {
					return jQuery(obj.selector+" .rev_slider").revkill();
				};

				// EXTEND THE AJAX CONTENT LOADING TYPES WITH TYPE AND FUNCTION
				var extendessential = setInterval(function() {
					if (jQuery.fn.tpessential != undefined) {
						clearInterval(extendessential);
						if(typeof(jQuery.fn.tpessential.defaults) !== 'undefined') {
							jQuery.fn.tpessential.defaults.ajaxTypes.push({type:"revslider",func:ajaxRevslider,killfunc:ajaxRemoveRevslider,openAnimationSpeed:0.3});   
							// type:  Name of the Post to load via Ajax into the Essential Grid Ajax Container
							// func: the Function Name which is Called once the Item with the Post Type has been clicked
							// killfunc: function to kill in case the Ajax Window going to be removed (before Remove function !
							// openAnimationSpeed: how quick the Ajax Content window should be animated (default is 0.3)
						}
					}
				},30);
			});
		</script>
		<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.lcctorch.com/?wordfence_lh=1&hid=0DCB622787E8473ADD2C5838C3BB2019');
</script><!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>
    

var tdBlocksArray = []; //here we store all the items for the current page

//td_block class - each ajax block uses a object of this class for requests
function tdBlock() {
    this.id = '';
    this.block_type = 1; //block type id (1-234 etc)
    this.atts = '';
    this.td_column_number = '';
    this.td_current_page = 1; //
    this.post_count = 0; //from wp
    this.found_posts = 0; //from wp
    this.max_num_pages = 0; //from wp
    this.td_filter_value = ''; //current live filter value
    this.is_ajax_running = false;
    this.td_user_action = ''; // load more or infinite loader (used by the animation)
    this.header_color = '';
    this.ajax_pagination_infinite_stop = ''; //show load more at page x
}

    
    
        // td_js_generator - mini detector
        (function(){
            var htmlTag = document.getElementsByTagName("html")[0];

            if ( navigator.userAgent.indexOf("MSIE 10.0") > -1 ) {
                htmlTag.className += ' ie10';
            }

            if ( !!navigator.userAgent.match(/Trident.*rv\:11\./) ) {
                htmlTag.className += ' ie11';
            }

            if ( /(iPad|iPhone|iPod)/g.test(navigator.userAgent) ) {
                htmlTag.className += ' td-md-is-ios';
            }

            var user_agent = navigator.userAgent.toLowerCase();
            if ( user_agent.indexOf("android") > -1 ) {
                htmlTag.className += ' td-md-is-android';
            }

            if ( -1 !== navigator.userAgent.indexOf('Mac OS X')  ) {
                htmlTag.className += ' td-md-is-os-x';
            }

            if ( /chrom(e|ium)/.test(navigator.userAgent.toLowerCase()) ) {
               htmlTag.className += ' td-md-is-chrome';
            }

            if ( -1 !== navigator.userAgent.indexOf('Firefox') ) {
                htmlTag.className += ' td-md-is-firefox';
            }

            if ( -1 !== navigator.userAgent.indexOf('Safari') && -1 === navigator.userAgent.indexOf('Chrome') ) {
                htmlTag.className += ' td-md-is-safari';
            }

        })();




        var tdLocalCache = {};

        ( function () {
            "use strict";

            tdLocalCache = {
                data: {},
                remove: function (resource_id) {
                    delete tdLocalCache.data[resource_id];
                },
                exist: function (resource_id) {
                    return tdLocalCache.data.hasOwnProperty(resource_id) && tdLocalCache.data[resource_id] !== null;
                },
                get: function (resource_id) {
                    return tdLocalCache.data[resource_id];
                },
                set: function (resource_id, cachedData) {
                    tdLocalCache.remove(resource_id);
                    tdLocalCache.data[resource_id] = cachedData;
                }
            };
        })();

    
    
var tds_smooth_scroll=true;
var td_viewport_interval_list=[{"limitBottom":767,"sidebarWidth":228},{"limitBottom":1018,"sidebarWidth":300},{"limitBottom":1140,"sidebarWidth":324}];
var td_animation_stack_effect="type0";
var tds_animation_stack=true;
var td_animation_stack_specific_selectors=".entry-thumb, img";
var td_animation_stack_general_selectors=".td-animation-stack img, .post img";
var td_ajax_url="http:\/\/www.lcctorch.com\/wp-admin\/admin-ajax.php?td_theme_name=Newspaper&v=6.6.5";
var td_get_template_directory_uri="http:\/\/www.lcctorch.com\/wp-content\/themes\/Newspaper";
var tds_snap_menu="snap";
var tds_logo_on_sticky="";
var tds_header_style="10";
var td_please_wait="Please wait...";
var td_email_user_pass_incorrect="User or password incorrect!";
var td_email_user_incorrect="Email or username incorrect!";
var td_email_incorrect="Email incorrect!";
var tds_more_articles_on_post_enable="show";
var tds_more_articles_on_post_time_to_wait="";
var tds_more_articles_on_post_pages_distance_from_top=400;
var tds_theme_color_site_wide="#1e73be";
var tds_smart_sidebar="";
var tdThemeName="Newspaper";
var td_magnific_popup_translation_tPrev="Previous (Left arrow key)";
var td_magnific_popup_translation_tNext="Next (Right arrow key)";
var td_magnific_popup_translation_tCounter="%curr% of %total%";
var td_magnific_popup_translation_ajax_tError="The content from %url% could not be loaded.";
var td_magnific_popup_translation_image_tError="The image #%curr% could not be loaded.";
var td_ad_background_click_link="";
var td_ad_background_click_target="";
</script>


<!-- Header style compiled by theme -->

<style>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</style>

<link rel="icon" href="http://www.lcctorch.com/wp-content/uploads/2019/02/cropped-torchflag-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://www.lcctorch.com/wp-content/uploads/2019/02/cropped-torchflag-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.lcctorch.com/wp-content/uploads/2019/02/cropped-torchflag-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://www.lcctorch.com/wp-content/uploads/2019/02/cropped-torchflag-270x270.jpg" />
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

.td-post-title .td-module-meta-info .td-post-views, .td-post-title .td-module-meta-info .td-post-comments, .td-module-meta-info .td-module-comments {
	display: none;
}
.td-main-content-wrap{
	/*background: url(http://www.lcctorch.com/wp-content/uploads/2018/01/downtownLCC.jpg) no-repeat center center fixed; */
	background: linear-gradient(to bottom, #2151a2 0%, #1474CE 100%);
}
.td-container{
	background: white;
	padding-left: 10px;
}
.td-footer-info{
	margin: 0px;
	background: black;
}
.td-pb-row{
	background: white;	
}
.td-header-top-menu{
	background: black;	
}
.vc_row{
	background: transparent;
}
.td-pb-span12{
	background: white;
	padding: 0px;
}
.td-main-content{
	background: white;
}
.td-main-sidebar{
	background: white;
}		</style>
	</head>

<body class="post-template-default single single-post postid-9659 single-format-standard come-rain-sleet-or-snow single_template_5 white-menu td-animation-stack-type0 td-boxed-layout" itemscope="itemscope" itemtype="http://schema.org/WebPage">




<div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

<div id="td-outer-wrap">

    <div class="td-transition-content-and-menu td-mobile-nav-wrap">
        <div id="td-mobile-nav">
    <!-- mobile menu close -->
    <div class="td-mobile-close">
        <a href="#">CLOSE</a>
        <div class="td-nav-triangle"></div>
    </div>

    <div class="td-mobile-content">
        <div class="menu-main_menu-container"><ul id="menu-main_menu" class=""><li id="menu-item-3632" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-3632"><a href="http://www.lcctorch.com/category/news/">News</a></li>
<li id="menu-item-3636" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-3636"><a href="http://www.lcctorch.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li id="menu-item-3637" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3637"><a href="http://www.lcctorch.com/category/sports/baseball/">Baseball</a></li>
	<li id="menu-item-3638" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3638"><a href="http://www.lcctorch.com/category/sports/basketball/">Basketball</a></li>
	<li id="menu-item-3639" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3639"><a href="http://www.lcctorch.com/category/sports/cross-country/">Cross Country</a></li>
	<li id="menu-item-3640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3640"><a href="http://www.lcctorch.com/category/sports/soccer/">Soccer</a></li>
	<li id="menu-item-3641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3641"><a href="http://www.lcctorch.com/category/sports/track-field/">Track &#038; Field</a></li>
	<li id="menu-item-3642" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3642"><a href="http://www.lcctorch.com/category/sports/volleyball/">Volleyball</a></li>
</ul>
</li>
<li id="menu-item-3633" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3633"><a href="http://www.lcctorch.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li id="menu-item-3634" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3634"><a href="http://www.lcctorch.com/category/opinion/editorial/">Editorial</a></li>
	<li id="menu-item-3635" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3635"><a href="http://www.lcctorch.com/category/opinion/letters/">Letters</a></li>
</ul>
</li>
<li id="menu-item-3627" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-3627"><a href="http://www.lcctorch.com/category/features/art/">Arts &#038; Entertainment</a>
<ul class="sub-menu">
	<li id="menu-item-3628" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3628"><a href="http://www.lcctorch.com/category/features/dance/">Dance</a></li>
	<li id="menu-item-3629" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3629"><a href="http://www.lcctorch.com/category/features/event/">Event</a></li>
	<li id="menu-item-3630" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3630"><a href="http://www.lcctorch.com/category/features/music/">Music</a></li>
	<li id="menu-item-6796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6796"><a href="http://www.lcctorch.com/category/features/reviews/">Reviews</a></li>
</ul>
</li>
<li id="menu-item-3689" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3689"><a target="_blank" href="https://issuu.com/torchnews">Print Archives</a></li>
</ul></div>    </div>
</div>    </div>

        <div class="td-transition-content-and-menu td-content-wrap">



<!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10">

	<div class="td-header-top-menu-full">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-header_menu" class="top-header-menu"><li id="menu-item-3657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-3657"><a href="http://www.lcctorch.com/contact/">Contact</a></li>
<li id="menu-item-5296" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-5296"><a href="http://www.lcctorch.com/advertising/">Advertising</a></li>
<li id="menu-item-3656" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3656"><a href="http://www.lcctorch.com/join-us/">Join Us</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    <span class="td-social-icon-wrap"><a target="_blank" href="http://www.instagram.com/thetorchnews/" title="Instagram"><i class="td-icon-font td-icon-instagram"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="http://www.lcctorch.com/feed" title="RSS"><i class="td-icon-font td-icon-rss"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="http://twitter.com/lcctorch" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span><span class="td-social-icon-wrap"><a target="_blank" href="http://www.youtube.com/channel/UCEgQMat8qjX_Lmapwy7PWug" title="Youtube"><i class="td-icon-font td-icon-youtube"></i></a></span></div>
    </div>

		</div>
	</div>

    <div class="td-banner-wrap-full td-logo-wrap-full">
        <div class="td-header-sp-logo">
            		<a class="td-logo" href="http://www.lcctorch.com/"><img src="http://www.lcctorch.com/wp-content/uploads/2019/01/torchflagrect-1024x388.jpg" alt="The Torch"/></a>

	        </div>
    </div>

	<div class="td-header-menu-wrap-full">
		<div class="td-header-menu-wrap td-header-gradient">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo">
                <a href="http://www.lcctorch.com/"><img src="http://www.lcctorch.com/wp-content/uploads/2019/01/torchflagrect-1024x388.jpg" alt="The Torch"/></a>
        </div>
    <div class="menu-main_menu-container"><ul id="menu-main_menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-3632"><a href="http://www.lcctorch.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children td-menu-item td-normal-menu menu-item-3636"><a href="http://www.lcctorch.com/category/sports/">Sports</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-3637"><a href="http://www.lcctorch.com/category/sports/baseball/">Baseball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3638"><a href="http://www.lcctorch.com/category/sports/basketball/">Basketball</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3639"><a href="http://www.lcctorch.com/category/sports/cross-country/">Cross Country</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3640"><a href="http://www.lcctorch.com/category/sports/soccer/">Soccer</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3641"><a href="http://www.lcctorch.com/category/sports/track-field/">Track &#038; Field</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3642"><a href="http://www.lcctorch.com/category/sports/volleyball/">Volleyball</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-3633"><a href="http://www.lcctorch.com/category/opinion/">Opinion</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3634"><a href="http://www.lcctorch.com/category/opinion/editorial/">Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3635"><a href="http://www.lcctorch.com/category/opinion/letters/">Letters</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children td-menu-item td-normal-menu menu-item-3627"><a href="http://www.lcctorch.com/category/features/art/">Arts &#038; Entertainment</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3628"><a href="http://www.lcctorch.com/category/features/dance/">Dance</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3629"><a href="http://www.lcctorch.com/category/features/event/">Event</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-3630"><a href="http://www.lcctorch.com/category/features/music/">Music</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-6796"><a href="http://www.lcctorch.com/category/features/reviews/">Reviews</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3689"><a target="_blank" href="https://issuu.com/torchnews">Print Archives</a></li>
</ul></div></div>


<div class="td-search-wrapper">
    <div id="td-top-search">
        <!-- Search -->
        <div class="header-search-wrap">
            <div class="dropdown header-search">
                <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            </div>
        </div>
    </div>
</div>

<div class="header-search-wrap">
	<div class="dropdown header-search">
		<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
			<form role="search" method="get" class="td-search-form" action="http://www.lcctorch.com/">
				<div class="td-head-form-search-wrap">
					<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
				</div>
			</form>
			<div id="td-aj-search"></div>
		</div>
	</div>
</div>			</div>
		</div>
	</div>

    <div class="td-banner-wrap-full td-banner-bg">
        <div class="td-container-header td-header-row td-header-header">
            <div class="td-header-sp-recs">
                <div class="td-header-rec-wrap">
    
</div>            </div>
        </div>
    </div>

</div><div class="td-main-content-wrap">

    <div class="td-container td-post-template-5 ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="" class="entry-crumb" itemprop="url" href="http://www.lcctorch.com/"><span itemprop="title">Home</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Sports" class="entry-crumb" itemprop="url" href="http://www.lcctorch.com/category/sports/"><span itemprop="title">Sports</span></a></span> <i class="td-icon-right td-bread-sep"></i> <span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a title="View all posts in Baseball" class="entry-crumb" itemprop="url" href="http://www.lcctorch.com/category/sports/baseball/"><span itemprop="title">Baseball</span></a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><meta itemprop="title" content = "Come rain, sleet or snow"><meta itemprop="url" content = "http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/">Come rain, sleet or snow</span></div></div>
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
    <article id="post-9659" class="post-9659 post type-post status-publish format-standard hentry category-baseball category-sports tag-artificial-turf tag-big-bend tag-donovan-baldocchi tag-head-coach-josh-blunt tag-josh-blunt tag-junior-college-baseball tag-lane-community-college tag-lane-head-coach-josh-blunt tag-lane-titans tag-matt-dallas tag-modesto-california tag-mt-hood-saints tag-non-conference-play tag-nwac tag-nwac-south tag-titan-baseball tag-titan-recruiting tag-titans tag-willamette-high-school" itemscope itemtype="http://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="http://www.lcctorch.com/category/sports/">Sports</a></li><li class="entry-category"><a  href="http://www.lcctorch.com/category/sports/baseball/">Baseball</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Come rain, sleet or snow</h1>

                                    <p class="td-post-sub-title">By March, the pitchers are ready to throw</p>
                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name">By <a href="http://www.lcctorch.com/author/marek-belka/" title="Posts by Marek Belka" class="author url fn" rel="author">Marek Belka</a> - </div>                    <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-27T16:46:21+00:00" >February 27, 2019</time></div>                    <div class="td-post-comments"><a href="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/#respond"><i class="td-icon-comments"></i>0</a></div>                    <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-9659">10</span></div>                </div>

            </header>

        </div>

        

        <div class="td-post-content">
            
<p class="has-drop-cap">Even on a sunny late winter afternoon, Titan head baseball coach Josh Blunt is worried about the rain. </p>



<p>In his office, Blunt repeatedly checks the weather forecast on his phone. The sun is shining through the windows and refracting through the crystal third-place trophies on his shelf, but Blunt isn’t convinced the weather will hold. He’s already canceled a week of practices and is weighing canceling the one scheduled for that afternoon.</p>



<p>The Northwest’s late winter deluge has reduced the field on Lane’s campus to a muddy swamp. As a result, the Titans spent their winter practicing at Sheldon or Willamette High Schools and on the artificial turf at the Willamalane facilities in Springfield.</p>



<p>“Oregon weather makes it tough to prepare for the season,” Blunt said. “Especially with facilities like ours that can’t handle the rain.” </p>



<p>In his seven seasons in Eugene, Blunt has tallied a 183-156 record and led the Titans to the playoffs the last five seasons. But last season’s Titans struggled against non-conference opponents and posted their first losing season under Blunt’s tenure–though they still snuck into the playoffs with a strong late-season conference push. </p>



<p>Blunt says this year’s roster is among the strongest he’s coached. He singled out redshirt freshman catcher Matt Dallas as “a special player” and believes he will be a top prospect for next year’s major league draft. Dallas attended high school in Modesto, California, where he recorded a .468 batting average and two MVP awards in his two years of varsity baseball. In addition to his skills as a catcher, Dallas also played outfield, second base and even threw a no-hitter as a pitcher in 2017.</p>



<p>Dallas will play an immediate role handling the Titans’ pitching staff, anchored by left-hander Riley Howard and right-hander Donovan Baldocchi, though Baldocchi will miss several weeks due to a thumb injury. Seven pitchers from last year’s roster are returning, bolstering Blunt’s optimism.</p>



<p>“We’ve got a lot of sophomores coming back who are ready to step up and get us back on track,” Blunt added.</p>



<p>Blunt’s talents as a recruiter are a double-edged sword for the Titans. While Blunt and his Oregon-grown coaching staff have a keen eye for untapped talent, that talent inevitably gets noticed by bigger schools and even professional teams. Nine players from last year’s Titans now play for Division I schools; Titan alumnus Keynan Middleton is a star relief pitcher for the Los Angeles Angels.</p>



<p>“That’s part of the challenge of junior college baseball,” Blunt said. “You don’t get to keep your guys for four years.”</p>



<p>Blunt doesn’t take all the credit for the Titans’ recruiting success. The baseball program at Lane, according to Blunt, has built a strong reputation for developing young players in spite of its “limited facilities and resources.”</p>



<p>With nine true freshman on the roster, the Titans–tied for ninth in NWAC preseason polls–are eager to prove themselves against stiff NWAC competition. The Titans were scheduled to open their season on Feb. 23 and 24 against ninth-ranked Everett and third-ranked Yakima Valley before rain and snow canceled baseball games all over the Northwest.</p>



<p>“It’s tough to lose early season matches against competition like that,” Blunt said. “It gives you an idea of where your team is at right at the start of the season.”</p>



<p>If Blunt and his team are worried about losing playing time against strong competition, their season schedule should relieve them. The Titans have 16 games against ranked non-conference opponents, including early season series against top-ranked Lower Columbia and #2 Edmonds. The Titans also have a pair of series each against ranked NWAC South rivals #4 Linn-Benton and #10 Mt. Hood.</p>



<p>Weather permitting, the Titans will start their season against Big Bend on March 2. <br></p>
        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing td-post-sharing-bottom td-with-like"><span class="td-post-share-title">SHARE</span>
            <div class="td-default-sharing">
	            <a class="td-social-sharing-buttons td-social-facebook" href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fwww.lcctorch.com%2F2019%2F02%2Fcome-rain-sleet-or-snow%2F" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-facebook"></i><div class="td-social-but-text">Facebook</div></a>
	            <a class="td-social-sharing-buttons td-social-twitter" href="https://twitter.com/intent/tweet?text=Come+rain%2C+sleet+or+snow&url=http%3A%2F%2Fwww.lcctorch.com%2F2019%2F02%2Fcome-rain-sleet-or-snow%2F&via=lcctorch"><i class="td-icon-twitter"></i><div class="td-social-but-text">Twitter</div></a>
	            <a class="td-social-sharing-buttons td-social-google" href="http://plus.google.com/share?url=http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-googleplus"></i></a>
	            <a class="td-social-sharing-buttons td-social-pinterest" href="http://pinterest.com/pin/create/button/?url=http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/&amp;media=&description=Come+rain%2C+sleet+or+snow" onclick="window.open(this.href, 'mywin','left=50,top=50,width=600,height=350,toolbar=0'); return false;"><i class="td-icon-pinterest"></i></a>
	            <a class="td-social-sharing-buttons td-social-whatsapp" href="whatsapp://send?text=Come+rain%2C+sleet+or+snow - http%3A%2F%2Fwww.lcctorch.com%2F2019%2F02%2Fcome-rain-sleet-or-snow%2F" ><i class="td-icon-whatsapp"></i></a>
            </div><div class="td-classic-sharing"><ul><li class="td-classic-facebook"><iframe frameBorder="0" src="http://www.facebook.com/plugins/like.php?href=http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></li><li class="td-classic-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/" data-text="Come rain, sleet or snow" data-via="" data-lang="en">tweet</a> <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li></ul></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="http://www.lcctorch.com/2019/02/review-andrea-andrew-gibson/">REVIEW: Andrea (Andrew) Gibson</a></div></div><div class="td-next-prev-separator"></div></div>            <div class="author-box-wrap"><div class="desc"><div class="td-author-name vcard author"><span class="fn"><a href="http://www.lcctorch.com/author/marek-belka/" title="Posts by Marek Belka" class="author url fn" rel="author">Marek Belka</a></span></div><div class="td-author-social"><span class="td-social-icon-wrap"><a target="_blank" href="https://twitter.com/mgbelka" title="Twitter"><i class="td-icon-font td-icon-twitter"></i></a></span></div><div class="clearfix"></div></div></div>            Marek Belka<span style="display: none;" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content=""></span><meta itemprop="datePublished" content="2019-02-27T16:46:21+00:00"><meta itemprop="dateModified" content="2019-02-27T16:46:23+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="http://www.lcctorch.com/2019/02/come-rain-sleet-or-snow/"/><span style="display: none;" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span style="display: none;" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.lcctorch.com/wp-content/uploads/2019/01/torchflagrect-1024x388.jpg"></span><meta itemprop="name" content="The Torch"></span><meta itemprop="headline " content="Come rain, sleet or snow"><span style="display: none;" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://www.lcctorch.com/wp-content/themes/Newspaper/images/no-thumb/td_meta_replacement.png"><meta itemprop="width" content="1068"><meta itemprop="height" content="580"></span>        </footer>

    </article> <!-- /.post -->

    <script>var block_td_uid_1_5c79b977e2bba = new tdBlock();
block_td_uid_1_5c79b977e2bba.id = "td_uid_1_5c79b977e2bba";
block_td_uid_1_5c79b977e2bba.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_tags","td_ajax_filter_type":"td_custom_related","class":"td_uid_1_5c79b977e2bba_rand","td_column_number":3,"live_filter_cur_post_id":9659,"live_filter_cur_post_author":"73"}';
block_td_uid_1_5c79b977e2bba.td_column_number = "3";
block_td_uid_1_5c79b977e2bba.block_type = "td_block_related_posts";
block_td_uid_1_5c79b977e2bba.post_count = "3";
block_td_uid_1_5c79b977e2bba.found_posts = "7";
block_td_uid_1_5c79b977e2bba.header_color = "";
block_td_uid_1_5c79b977e2bba.ajax_pagination_infinite_stop = "";
block_td_uid_1_5c79b977e2bba.max_num_pages = "3";
tdBlocksArray.push(block_td_uid_1_5c79b977e2bba);
</script><div class="td_block_wrap td_block_related_posts td_uid_1_5c79b977e2bba_rand td_with_ajax_pagination td-pb-border-top"><h4 class="td-related-title"><a id="td_uid_2_5c79b977eaea0" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_1_5c79b977e2bba" href="#">RELATED ARTICLES</a><a id="td_uid_3_5c79b977eaea4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_1_5c79b977e2bba" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_1_5c79b977e2bba class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.lcctorch.com/2018/05/titans-edge-past-bulldogs/" rel="bookmark" title="Titans edge past Bulldogs"><img width="218" height="150" class="entry-thumb" src="http://www.lcctorch.com/wp-content/uploads/2018/05/IMG_9458-218x150.jpg" alt="" title="Titans edge past Bulldogs"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.lcctorch.com/2018/05/titans-edge-past-bulldogs/" rel="bookmark" title="Titans edge past Bulldogs">Titans edge past Bulldogs</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.lcctorch.com/2018/05/titans-prepare-for-playoffs/" rel="bookmark" title="Titans prepare for playoffs"><img width="218" height="150" class="entry-thumb" src="http://www.lcctorch.com/wp-content/uploads/2018/05/IMG_8857-218x150.jpg" alt="" title="Titans prepare for playoffs"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.lcctorch.com/2018/05/titans-prepare-for-playoffs/" rel="bookmark" title="Titans prepare for playoffs">Titans prepare for playoffs</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="http://www.lcctorch.com/2018/05/lane-clinches-playoff-spot/" rel="bookmark" title="Lane clinches playoff spot"><img width="218" height="150" class="entry-thumb" src="http://www.lcctorch.com/wp-content/uploads/2018/05/IMG_4728-218x150.jpg" alt="" title="Lane clinches playoff spot"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="http://www.lcctorch.com/2018/05/lane-clinches-playoff-spot/" rel="bookmark" title="Lane clinches playoff spot">Lane clinches playoff spot</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_1_5c79b977e2bba" data-td_block_id="td_uid_1_5c79b977e2bba"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_1_5c79b977e2bba" data-td_block_id="td_uid_1_5c79b977e2bba"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
<div id="disqus_thread">
		</div>
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">
<a target="_blank" href="https://www.eou.edu/roseburg/">
<img style="margin-top:10px;" src="https://i2.wp.com/www.lcctorch.com/wp-content/uploads/2018/04/EOU_Web-ad_040918.png?w=330" alt="ad"  data-recalc-dims="1">
</a>

<a target="_blank" href="https://www.pacificu.edu/academics/colleges/college-education/school-learning-teaching/preliminary-licensure-programs/teaching-english-language-learning-bed"><img class ="alignright" style="margin-top:5px; text-align: center;" src="https://i1.wp.com/www.lcctorch.com/wp-content/uploads/2019/02/PacU_BEd_LCC-Torch_250x300_Ad.jpg?w=640" data-recalc-dims="1">
</a>
</div></aside><script>var block_td_uid_4_5c79b977ee747 = new tdBlock();
block_td_uid_4_5c79b977ee747.id = "td_uid_4_5c79b977ee747";
block_td_uid_4_5c79b977ee747.atts = '{"custom_title":"Popular Posts","custom_url":"","header_text_color":"#","header_color":"#","post_ids":"","category_id":"","category_ids":"","tag_slug":"","autors_id":"","installed_post_types":"","sort":"jetpack_popular_2","limit":"5","offset":"5","td_ajax_filter_type":"","td_ajax_filter_ids":"","td_filter_default_txt":"All","td_ajax_preloading":"","ajax_pagination":"","ajax_pagination_infinite_stop":"","class":"td_block_widget td_uid_4_5c79b977ee747_rand"}';
block_td_uid_4_5c79b977ee747.td_column_number = "1";
block_td_uid_4_5c79b977ee747.block_type = "td_block_7";
block_td_uid_4_5c79b977ee747.post_count = "0";
block_td_uid_4_5c79b977ee747.found_posts = "0";
block_td_uid_4_5c79b977ee747.header_color = "#";
block_td_uid_4_5c79b977ee747.ajax_pagination_infinite_stop = "";
block_td_uid_4_5c79b977ee747.max_num_pages = "-1";
tdBlocksArray.push(block_td_uid_4_5c79b977ee747);
</script><div class="td_block_wrap td_block_7 td_block_widget td_uid_4_5c79b977ee747_rand td_with_ajax_pagination td-pb-border-top"><h4 class="block-title"><span>Popular Posts</span></h4><div id=td_uid_4_5c79b977ee747 class="td_block_inner"></div></div> <!-- ./block -->                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->


<!-- Footer -->


<!-- Sub Footer -->
    <div class="td-sub-footer-container">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span7 td-sub-footer-menu">
                        <div class="menu-footer_menu-container"><ul id="menu-footer_menu" class="td-subfooter-menu"><li id="menu-item-5299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-5299"><a href="http://www.lcctorch.com/advertising/">Advertising</a></li>
<li id="menu-item-3688" class="menu-item menu-item-type-custom menu-item-object-custom td-menu-item td-normal-menu menu-item-3688"><a href="https://issuu.com/torchnews">Print Archives</a></li>
<li id="menu-item-3660" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3660"><a href="http://www.lcctorch.com/contact/">Contact</a></li>
<li id="menu-item-3661" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-3661"><a href="http://www.lcctorch.com/join-us/">Join Us</a></li>
</ul></div>                </div>

                <div class="td-pb-span5 td-sub-footer-copy">
                    &copy; The Torch Media Organization. All Rights Reserved.                </div>
            </div>
        </div>
    </div>
    </div><!--close content div-->
</div><!--close td-outer-wrap-->

                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_6 td_module_wrap td-animation-stack">

        <div class="td-module-thumb"><a href="http://www.lcctorch.com/2018/06/supported-by-listeners-like-you/" rel="bookmark" title="‘Supported by listeners like you’"><img width="100" height="70" class="entry-thumb" src="http://www.lcctorch.com/wp-content/uploads/2018/06/IMG_5277-100x70.jpg" alt="" title="‘Supported by listeners like you’"/></a></div>
        <div class="item-details">
            <h3 class="entry-title td-module-title"><a href="http://www.lcctorch.com/2018/06/supported-by-listeners-like-you/" rel="bookmark" title="‘Supported by listeners like you’">‘Supported by listeners like you’</a></h3>            <div class="td-module-meta-info">
                                                <div class="td-post-date"><time class="entry-date updated td-module-date" datetime="2018-06-08T11:00:32+00:00" >June 8, 2018</time></div>                            </div>
        </div>

        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv 2015
        Version: 6.6.5 (rara)
        Deploy mode: deploy
        
        uid: 5c79b9780f4dc
    -->

    <script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"lcctorch"};
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"9659 http:\/\/www.lcctorch.com\/?p=9659","disqusShortname":"lcctorch","disqusTitle":"Come rain, sleet or snow","disqusUrl":"http:\/\/www.lcctorch.com\/2019\/02\/come-rain-sleet-or-snow\/","postId":"9659"};
var dclCustomVars = {"dcl_progress_text":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.lcctorch.com/wp-content/plugins/disqus-conditional-load/assets/js/public/embed-scroll.min.js?ver=11.0.0'></script>
<script type='text/javascript' src='http://www.lcctorch.com/wp-content/themes/Newspaper/js/tagdiv_theme.js?ver=6.6.5'></script>
<script type='text/javascript' src='http://www.lcctorch.com/wp-includes/js/wp-embed.min.js?ver=0bd67b5fa4a1428b3843394fb8943642'></script>

<!-- JS generated by theme -->

<script>
    

                jQuery().ready(function jQuery_ready() {
                    tdAjaxCount.tdGetViewsCountsAjax("post","[9659]");
                });
            

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'http://www.lcctorch.com/wp-content/themes/Newspaper-child/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'http://www.lcctorch.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>


</body>
</html>